NR worked for the past year, stopped working recently.

Running sudo net-responsibility -tr would return a libpoco error. As per, I redownloaded poco full and recompiled from source, including recompiling unixODBC as well. Now, I get this error: sudo net-responsibility -tr
net-responsibility: symbol lookup error: /usr/lib/ undefined symbol: _pcre_ucd_stage1

Any ideas? Running Ubuntu 14.10, kernel 3.17.0-031700-generic


  • I've solved the problem: you need to install Poco 1.4.1 from here: and in the ./Data/ODBC folder, edit the Makefile so the ODBC points to you PDBC install location, as it isn't automatically working.

  • Hey Penguin. Glad you figured it out! The documentation for installing from source isn't as complete as it should be. We're working on it though.

    If you're going to the trouble of installing from source, you might as well download the latest dev version. It has some pretty cool new features. You can clone the latest source from our repo at

    Hope you enjoy using it!

  • What are the new features?

  • The biggest new feature is a completely redesign email report that's much easier to understand. There were some pretty big improvements to the parsing of urls, so it's a lot faster. Lots of bug fixes and general improvements. If you already have the poco stuff compiled and installed, it shouldn't be hard to get the new version up and running.

    This new version is still under development so it hasn't been released yet, but it's pretty stable in the repo right now. Check it out and let us know what you think!

Sign In or Register to comment.