Can't install on Ubuntu 14.10

I'm getting errors when I try to compile Net Responsibility on Ubuntu 14.10. Has anyone had success installing this on 14.10?

Thanks!

Error report:

chris@Chris-XPS:~/poco-1.4.7p1-all$ make
make -C /home/chris/poco-1.4.7p1-all/Foundation
make[1]: Entering directory '/home/chris/poco-1.4.7p1-all/Foundation'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/home/chris/poco-1.4.7p1-all/Foundation'
make -C /home/chris/poco-1.4.7p1-all/XML
make[1]: Entering directory '/home/chris/poco-1.4.7p1-all/XML'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/home/chris/poco-1.4.7p1-all/XML'
make -C /home/chris/poco-1.4.7p1-all/Util
make[1]: Entering directory '/home/chris/poco-1.4.7p1-all/Util'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/home/chris/poco-1.4.7p1-all/Util'
make -C /home/chris/poco-1.4.7p1-all/Net
make[1]: Entering directory '/home/chris/poco-1.4.7p1-all/Net'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/home/chris/poco-1.4.7p1-all/Net'
make -C /home/chris/poco-1.4.7p1-all/Crypto
make[1]: Entering directory '/home/chris/poco-1.4.7p1-all/Crypto'
** Compiling src/CipherFactory.cpp (debug, shared)
g++ -Iinclude -I/home/chris/poco-1.4.7p1-all/CppUnit/include -I/home/chris/poco-1.4.7p1-all/Foundation/include -I/home/chris/poco-1.4.7p1-all/XML/include -I/home/chris/poco-1.4.7p1-all/Util/include -I/home/chris/poco-1.4.7p1-all/Net/include -I/home/chris/poco-1.4.7p1-all/Crypto/include -I/home/chris/poco-1.4.7p1-all/NetSSL_OpenSSL/include -I/home/chris/poco-1.4.7p1-all/Data/include -I/home/chris/poco-1.4.7p1-all/Data/SQLite/include -I/home/chris/poco-1.4.7p1-all/Data/ODBC/include -I/home/chris/poco-1.4.7p1-all/Data/MySQL/include -I/home/chris/poco-1.4.7p1-all/Zip/include -I/home/chris/poco-1.4.7p1-all/PageCompiler/include -I/home/chris/poco-1.4.7p1-all/PageCompiler/File2Page/include -Wall -Wno-sign-compare -DPOCO_BUILD_HOST=Chris-XPS -D_XOPEN_SOURCE=500 -D_REENTRANT -D_THREAD_SAFE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -DPOCO_HAVE_FD_EPOLL -g -D_DEBUG -fPIC -c src/CipherFactory.cpp -o /home/chris/poco-1.4.7p1-all/Crypto/obj/Linux/x86_64/debug_shared/CipherFactory.o
In file included from include/Poco/Crypto/CipherKeyImpl.h:44:0,
from include/Poco/Crypto/CipherKey.h:44,
from src/CipherFactory.cpp:39:
include/Poco/Crypto/OpenSSLInitializer.h:45:33: fatal error: openssl/opensslconf.h: No such file or directory
#include <openssl/opensslconf.h>
^
compilation terminated.
/home/chris/poco-1.4.7p1-all/build/rules/compile:53: recipe for target '/home/chris/poco-1.4.7p1-all/Crypto/obj/Linux/x86_64/debug_shared/CipherFactory.o' failed
make[1]: *** [/home/chris/poco-1.4.7p1-all/Crypto/obj/Linux/x86_64/debug_shared/CipherFactory.o] Error 1
make[1]: Leaving directory '/home/chris/poco-1.4.7p1-all/Crypto'
Makefile:98: recipe for target 'Crypto-libexec' failed
make: *** [Crypto-libexec] Error 2

Comments

  • I've updated the PPA, so it should work with Ubuntu 14.10 too. It can take a while for them to process. Try to install NR through the PPA in a couple of hours.

  • I also received the same error when attempting to compile as the PPA was not working for me. The error I received when attempting to install via PPA is the following:

    net-responsibility: symbol lookup error: /usr/lib/libPocoFoundation.so.16: undefined symbol: _pcre_ucd_stage1

    I hope this is helpful.

    Thanks,

    Luke Morrison

  • I was able to move past the original compilation error by installing libssl-dev, but then I got stuck on the ODBC piece. I tried installing both iodbc and unixodbc and neither made any difference. I don't know if they conflicted, but both gave the same error

  • edited January 2015

    I am having the same difficulties with installing this program. When I followed the PPA instructions, the first 2 commands work fine, but the third one, sudo apt-get install net-responsibility, eventually throws the error:

    Setting up net-responsibility (3.0.3-1) ...
    mkdir: cannot create directory ‘/usr/share/net-responsibility/reports’: File exists
    dpkg: error processing package net-responsibility (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    net-responsibility
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    I am BRAND NEW to Ubuntu and have been using Windows for decades prior to this. As such, maybe there's a really cut and dry solution to this, but I'm totally lost as to how to figure it out. It is quite over my head. I seem to have found that other users in other forums have also complained that they found no satisfactory way to install your program on Ubuntu 14.10. Is a solution forthcoming? Many thanks, sir.

  • I'm also having problems installing. I get an error after installation (net-responsibility subprocess installed post-installation script returned error exit status 1). This error also pops up even when installing different packages after net-responsibility is installed. Also, when I try to run net-responsibility from the command line, I get this error: "net-responsibility: symbol lookup error: /usr/lib/libPocoFoundation.so.16: undefined symbol: _pcre_ucd_stage1".

  • I'm having the same error as ChrisN, and if I remove the said folder, I get the same error as 1John5vs7. Has there been any progress on fixing this issue? I can't get NR installed!

  • Sorry for not responding sooner, I must check if I can get automatic notifications somehow.

    It seems like the pcre library has been updated and broken poco, which NR relies on. This has happened before, and it was possible then to downgrade the libpcre package, to make it work with libpoco. It might cause problems with other packages, but not for sure. This could be a quickfix for the adventurous.

    The best thing to do would be to develop NR to work with poco 1.6 (@mpnordland has initiated some work on that), but it might take some time. Personally I don't have much time to hack on NR at the moment unfortunately. If this is a real deal-breaker, then it might be worth running Ubuntu 14.04. Another option would of course be to dig into the code and fix the problem yourself ;)

    One note on compiling Poco. You don't need to compile the components that require ODBC, OpenSSL, etc. configure with this command to omit them:

    ./configure --shared --no-tests --no-samples --omit=Data/MySQL,Data/ODBC,Crypto,PageCompiler,PageCompiler/File2Page,NetSSL_OpenSSL,CppUnit
    

    That will smoothen out some of the obstacles.

    I'll try to follow this thread, please update us if you make any progress on this issue!

  • To confirm: I had thought that my laptop on which I had Xubuntu 14.04 64-bit, which I upgraded to 14.10 64-bit, had NR running just fine. Turns out it's not working, either. The diagnostics on the troubleshooting page: http://netresponsibility.com/documentation.php?id=0309-TroubleshootingInstallation all come back negative. The command

    sudo net-responsibility -r

    yields the output

    net-responsibility: symbol lookup error: /usr/lib/libPocoFoundation.so.16: undefined symbol: _pcre_ucd_stage1

    I would take this as confirmation of roggan's statement in the previous post.

    I'm going to have to stop using this computer until the issue is settled. I can run basic tests and all, but I am no coder.

    Please fix this quickly!

    One thought: if the dependency on outside packages could be reduced, or perhaps better yet: you just package (maybe in a sandbox or something so it doesn't interfere with other packages) any outside code you need, then the installation would probably be a lot more consistent.

  • I've just upgraded my own Ubuntu box to 14.04 (I know, I'm a bit late). Net Responsibility seems to be working fine when installing from the PPA. As far as I can tell the dependency issue is introduced in 14.10 then. My recommendation would be to downgrade to 14.04 if NR is that crucial (which I know it is to many). As for me, I'd much rather have a little outdated version of Ubuntu than having to stop using the computer.

    Regarding the suggestion to break out all relevant code and use it separately, it would be a lot more work, and be a lot buggier, so unfortunately that is not an option.

    There are several reasons I haven't been able to keep up with this project, but hopefully I'll get more time for it somewhere in the future, possibly in the summer to come.

  • Well, for me, the issue is that I've already installed 14.10 on all my Linux machines. So I would have to wipe the hard drive, and install an enormous amount of software (including TeXlive, which takes a very long time). It's essentially an entire day of lost productivity. I am borrowing a Windows machine right now, and it's a good machine, and I have Covenant Eyes on it. Accountability software is really a necessity for me; unfortunately, I can't rely on "hopefully I'll get more time for it somewhere in the future". The problem with downgrading to 14.04 isn't that I couldn't get it working. The problem is that, eventually, all the other software on the computer, if you do the normal upgrades, is going to be crying out for 14.10. Canonical can say LTS all they want, but the other software writers don't always follow suit. Sometimes they plow on, regardless.

    From my perspective, alas, Linux is pretty much dead in the water until NR is a fully maintained software package, or until (that would be the day!) Covenant Eyes gets a Linux version fully operational, or something of the like happens. I do hope one of those two happens very soon, because I simply can't keep on recommending Linux to non-profits like Christian schools and churches if there is no accountability software available!

  • Ackbach, I understand your frustration, otherwise I would never have put those hundreds, or probably even thousands of hours in developing this software. I'm sorry it'll take you a day to downgrade. I'm sorry you feel like you're unable to use your linux machines. However, it doesn't forces me to put my family aside, resign from my church commitments, etc. Sorry you're not a programmer, then you could have got this working for all of us, and I can promise you, that would taken more time than downgrading to 14.04. Hope you understand, and I'm sorry if you don't. I wish you the best!

  • And I can totally understand you not wanting to neglect your family (isn't that what this is all about, anyway?) or your church to do this task. You've got to major on the majors.

    I can program some, but it would take an enormous amount of time to get up to speed on a project like NR, including learning new languages, existing packages, etc. Maybe Covenant Eyes will see this event as an opportunity. I personally don't much care who gets accountability SW for Linux, I just want at least one good one!

  • Glad you understand. Several people have tried to convince Covenant Eyes to make their software available for Linux, but without success. You can read this thread from 2009 and the comments: http://www.covenanteyes.com/2009/06/10/covenant-eyes-for-linux/

    Well, let's not get too much off topic. Hope you'll find a solution that suits you.

  • edited May 2015

    I got this same error while trying to install on Ubuntu 14.10 and solved it as follows:

    Step 1: get the version of libpcre3 from ubuntu 14.04 (1:8.31-2ubuntu2) here: http://packages.ubuntu.com/trusty/libpcre3

    You will need to choose either 32-bit or 64-bit depending on which version of ubuntu you are running.

    Step 2: In the directory you downloaded that .deb file, from the command line type:

    sudo dpkg -i libpcre3_8.31-2ubuntu2_amd64.deb

    Note that example uses the 64-bit version. I got a warning message "warning: downgrading libpcre3:amd64 from 1:8.35-3ubuntu1 to 1:8.31-2ubuntu2" but I did not need to use the --force-all switch

    I then tried to install net responsibility again (since the error I got was on install), but it told me it was already installed, so . . .

    Step 3: From the command line, type:

    sudo net-responsibility

    to launch net-responsibility, and it seemed to work! (I think. It got stuck on "downloading blacklists", but I restarted Ubuntu and then checked to see if it is running and it said "Net Responsibility seems to be up and running").

    Step 4 (optional): If you don't want ubuntu to auto-upgrade libpcre3 to the latest version (which would presumably break net responsibility again), you can type:

    echo "libpcre3 hold" | sudo dpkg --set-selections

    Which locks libpcre3 at the old version. If Net Responsibility gets fixed, you can remove the hold with:

    echo "libpcre3 install" | sudo dpkg --set-selections

    I note there is a new version of ubuntu available (15.04, or "vivid") but I'm not brave enough to try upgrading yet. If someone else tries installing on that version, let us know how it goes!

  • Thanks @danrminster for your step by step instructions! Just a word of caution. This is still only a workaround and might affect other installed programs negatively. If you find Net responsibility crucial enough, it's definitely worth a try!

  • edited May 2015

    Sadly, I have not yet succeeded in getting NR installed, despite the apparent success above. It always hangs on "Downloading blacklists" and I only ever saw one report get emailed out (saying that there was some kind of tampering with the blacklists, presumably because they were never correctly installed). If anybody knows what to do next I'd appreciate the help. I emailed the devs about it, and although I got a response from them before fairly quickly, no response for a few days on this issue. I know they're busy . . .

  • A build script that will successfully compile NR for Ubuntu 14.10 or 15.04 is available at http://www.pluckeye.net/net-responsibility/build.sh . If you have questions about it, feel free to use http://www.pluckeye.net/contact.html .

  • That looks super cool @plujon3! Thanks for writing that, I hope people find it helpful.

    We definitely need to fix the compatibility bug with Poco...hopefully we can soon.

  • I sure found the script helpful! Worked like a pro for me. Thanks plujon3!

  • A build script that will successfully compile NR for Ubuntu 14.10 or 15.04 is available at http://www.pluckeye.net/net-responsibility/build.sh .

    That worked perfectly for Ubuntu 16.04 when all other suggestions failed (or I failed in carrying them out.)

    Thanks, plujon3!

Sign In or Register to comment.