Installing Error During Net Responsibility Make command

I am getting the following when after I run the make command for Net Responsibility:

/Library/Developer/CommandLineTools/usr/bin/make  all-am
/bin/sh ./libtool  --tag=CXX   --mode=compile g++ -DHAVE_CONFIG_H -I.  -I./include  -DPKGDATADIR='/usr/share/net-responsibility' -DPKGLIBDIR='/usr/lib/net-responsibility' -DDATABASEDIR='/var/log' -DPIDDIR='/var/run'   -I./include  -g -O2 -g -O2 -MT ./src/libNetResponsibility_la-MainApplication.lo -MD -MP -MF ./src/.deps/libNetResponsibility_la-MainApplication.Tpo -c -o ./src/libNetResponsibility_la-MainApplication.lo `test -f './src/MainApplication.cpp' || echo './'`./src/MainApplication.cpp
libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I./include -DPKGDATADIR=/usr/share/net-responsibility -DPKGLIBDIR=/usr/lib/net-responsibility -DDATABASEDIR=/var/log -DPIDDIR=/var/run -I./include -g -O2 -g -O2 -MT ./src/libNetResponsibility_la-MainApplication.lo -MD -MP -MF ./src/.deps/libNetResponsibility_la-MainApplication.Tpo -c ./src/MainApplication.cpp  -fno-common -DPIC -o ./src/.libs/libNetResponsibility_la-MainApplication.o
In file included from ./src/MainApplication.cpp:21:
In file included from ./include/MainApplication.h:34:
In file included from ./include/Options.h:33:
In file included from ./include/MyXml.h:38:
./include/Blacklist.h:33:10: fatal error: 'Poco/Data/Common.h' file not found
#include "Poco/Data/Common.h"
1 error generated.
make[1]: *** [src/libNetResponsibility_la-MainApplication.lo] Error 1
make: *** [all] Error 2

Thanks for the help.


  • Hi!

    What system are you compiling on? Have you successfully installed Poco, if so, how?

  • I'm compiling on Mac OSX 10.10.1. I was able to get get Poco installed with no errors when I did the following command:

    ./configure --shared --no-tests --no-samples --omit=Data/MySQL,Data/ODBC,Crypto,PageCompiler,PageCompiler/File2Page,NetSSL_OpenSSL,CppUnit.

    I used that command because I was getting the follow error:

    /Poco/Data/ODBC/Unicode.h:33:10 error 'sqlext.h' file not found.

    I found the above information from the following link:

  • I am getting precisely the same error. Everything worked just perfectly about a week ago with Poco 1.5.4, but then I upgraded to Poco 1.6.0 and my build is now broken in the same exact way. I suppose Poco 1.6 has broken NR somehow.

  • Sorry, the version of Poco that I had it working with was actually 1.4.7

  • Just want to oonfirm that chase is right. Poco 1.6 is apparently not backwards-compatible. @mpnordland is working on making NR compatible with poco 1.6. Are you able to compile with an older version of Poco, such as 1.4.7?

Sign In or Register to comment.