Timeout Report could not be sent - firewall issue ?


I'm running nr 3.0.3-1 on Ubuntu Studio 14.04.

I'm using an institutional Internet access with certain limitations, especially having just a few port open. I suppose this prevents nr to send report (Apparently, nr needs port 2525 to be open, as said there forum.netresponsibility.com/discussion/comment/546/#Comment_546).
I tried to send report with "sudo net-responsibility -tr" which failed :

Starting Net Responsibility

Loading options

Connecting to database

Generating report

Sending report


Report could not be sent

Other instance found

Shutting down Net Responsibility

How can I make nr to use another port ?

Thank you in advance,



  • edited October 2015

    Hello there @Vacatour,

    You should be able to change the port in the config.xml file, which is probably located in:

    Try and and see if it fixes your issue

  • Hello @Erreth,

    Thanks for your answer. I indeed found a port line in the config.xml file, and changing it to 587 made it possible for nr to send reports. But each time nr downloads my options, it turns the port back to 2525.
    Is there a way to block the port, or could I write a script to change it back to 587 each time nr modifies it ?

    Thanks again.

  • Hmm, that's a good question. I'm not entirely sure about that. Unless Robert or Micah can chime in, I don't know.

    Maybe an easier way would be to redirect port 2525 to port 587 using iptables or SSH forwarding. Maybe something like:

    iptables -t nat -A OUTPUT -o lo -p tcp --dport 2525 -j REDIRECT --to-port 587


    sudo ssh -gL 2525: localhost

    Note, those are untested. They might require some fixing.

  • Thank you very much. Problem solved with iptables. I made some research and this line seems to work :

    iptables -t nat -A OUTPUT -p tcp -d send.one.com --dport 2525 -j DNAT --to-destination :587

  • edited December 2017
    Yes, thanx a lot for this code because it helped me too
Sign In or Register to comment.