make on poco 1.6.1 fails on Debian

Hi there,

I'm running Debian x86_64 with kernel 3.16.0-4. I have libpcap-dev installed (apt-get can't find a package for just libpcap). Now when I do a ./configure --shared --no-tests --no-samples, everything is just fine and I get the message: "Configured for Linux". However if I then try to "make" I'm running into problems and get an error message

include/Poco/Crypto/OpenSSLInitializer.h:26:28: fatal error: openssl/crypto.h: file or directory not found

What am I missing?



  • Welcome! poco 1.6 has a breaking change. The only solution right now is to downgrade poco to 1.4.*

    It might work with poco 1.5, I'm not entirely sure.

  • Ho do I downgrade?

    Un-install poco 1.6 and re-install poco 1.4?

    Where do I get poco 1.4?

    Why haven't the instructions been modified here:

    to include a link to poco 1.4?

    Has anyone successfully installed NR on to a debian system? I'm using Debian 8 'Jessie'

    I was really looking forward to using this software and getting an accountability partner, so hope I can get it running.

    Thanks for any additional help.


  • Okay, I just found out that accountability software isn't a prerequisite for having an accountability partner on nonfap!

    For the record, I tried Poco 1.4.7 and got the same error message when attempting 'make':

    compilation terminated.
    /home/****/poco/build/rules/compile:53: recipe for target '/home/****/poco/Crypto/obj/Linux/x86_64/debug_shared/CipherFactory.o' failed
    make[1]: *** [/home/****/poco/Crypto/obj/Linux/x86_64/debug_shared/CipherFactory.o] Error 1
    make[1]: Leaving directory '/home/****/poco/Crypto'
    Makefile:139: recipe for target 'Crypto-libexec' failed
    make: *** [Crypto-libexec] Error 2

    Note: **** denotes my home directory


Sign In or Register to comment.