make error when compiling netresponsibility

Hi there,

I solved an earlier issue I had due to poco 1.6.1 not working with the great help of this forum. I am now able to compile and install poco 1.4.7, but when I try to install netresponsibility 3.0.2 or 3.0.3 I get the following errors (I am only including the last chunk that seems relevant. If you need more, just let me know.)

./src/Database.cpp:765:35: note: suggested alternative:
In file included from /usr/include/Poco/Data/Common.h:44:0,
from ./include/Database.h:26,
from ./src/Database.cpp:20:
/usr/local/include/Poco/Data/Binding.h:1446:28: note: 'Poco::Data::Keywords::use'
inline AbstractBindingVec& use(AbstractBindingVec& bv)
^
./src/Database.cpp:765:38: error: 'now' was not declared in this scope
into(keywords), use(urlId[i]), now;
^
./src/Database.cpp:765:38: note: suggested alternative:
In file included from /usr/local/include/Poco/Data/Session.h:25:0,
from /usr/local/include/Poco/Data/SessionFactory.h:25,
from /usr/include/Poco/Data/Common.h:47,
from ./include/Database.h:26,
from ./src/Database.cpp:20:
/usr/local/include/Poco/Data/Statement.h:439:22: note: 'Poco::Data::Keywords::now'
inline void Data_API now(Statement& statement)
^
Makefile:690: recipe for target 'src/libNetResponsibility_la-MainApplication.lo' failed
make[1]: *** [src/libNetResponsibility_la-MainApplication.lo] Error 1
Makefile:704: recipe for target 'src/libNetResponsibility_la-Bypasses.lo' failed
make[1]: *** [src/libNetResponsibility_la-Bypasses.lo] Error 1
Makefile:718: recipe for target 'src/libNetResponsibility_la-Database.lo' failed
make[1]: *** [src/libNetResponsibility_la-Database.lo] Error 1
make[1]: Leaving directory '/home/ben/net-responsibility-3.0.2'
Makefile:348: recipe for target 'all' failed
make: *** [all] Error 2

Can anyone solve this or give me a hint on how to narrow down the problem?

Thanks again
Ben

Sign In or Register to comment.