Failed to send report: SMTP service unavailable

When trying to test if reports are being sent successfully I get the following:

sudo net-responsibility -tr
Starting Net Responsibility
Loading options
Downloading configuration file
Downloading blacklists
Downloading configuration file
Downloading blacklists
Downloading configuration file
Downloading blacklists
Connecting to database
Generating report
Sending report
SMTP Exception: The mail service is unavailable
Report could not be sent
Other instance found
Shutting down Net Responsibility

I am running NR on Ubuntu 16.04.

Any ideas how to fix this?

Comments

  • Hey Nathan,

    I assume you're running 3.0.3 or some 3.0 version? We were using a specific port + protocol with one.com (the SMTP server we use) that was deprecated.

    We've updated the settings in the latest version of master but we haven't released it yet. One.com now requires TLS -- at least with the new settings we're using.

    The solution right now is to download the source from bitbucket and compile it manually. All previously released versions do not support TLS and so will not work.

    I know this is pretty crummy...sorry about that.
  • Ah ok, yeah I'm using 3.0.3. Source it is then.

    Thanks for the feedback!
  • Absolutely, no worries!

    Regarding the source -- one of the dependencies is the Poco Library. Any of the versions, including the latest (1.7.8 I think) should work just fine.

    Additionally, in the latest NR source we're now requiring openssl. That dependency isn't yet listed on our website but you'll get an error if you don't have it :smile:

    If you have any questions or run into any problems please don't hesitate to ask on here or on our mailing list.
  • edited March 2017
    Hi, I'm also getting the same SMTP exception as Nathan.

    I'm currently running 3.0.3 for Net Responsibility and 1.4.7 for Poco Library. I tried compiling it manually from the source (following this page) but still got the same error message.

    Anything would help, thanks!
  • I'm having the same issue!

    I tried compiling net-responsibility 3.0.3 with the updated Poco 1.7.8 library, but these two are not compatible. And then like Samuel, compiling from source for 3.0.3 and 1.4.7 successfully installs but still gives the STMP Exception error.

    If it is a TLS issue like noted, then I'm guessing there is some configuration or some setting that has to be changed for net-responsibility to use the right protocol?

    Nathan: were you able to find a solution? I'm also running Ubuntu 16.04.
  • @Samuel Park and @Willis :

    NR 3.0.3 will not work with Poco 1.7.8. You need to use the latest NR source straight from Bitbucket. 3.0.3 does not support SSL/TLS so I'm pretty sure you won't be able to get it working.

    If you're running Ubuntu 16.04 you're also running systemd. There is a pull request in review right now that fixes the systemd scripts so it should start and stop properly.

    The installation instructions should be the same as for 3.0.3 except 4.0 requires Openssl as an additional required dependency.

    If we can get the pending pull request tested and merged in, Robert can create an alpha build in the Ubuntu PPA and make large scale testing of this much easier.

  • @Corey Watts:

    I ran the build.sh script recommended on the following forum post and am getting the same issue.

    https://forum.netresponsibility.com/discussion/159/can-t-install-on-ubuntu-14-10

    It uses poco 1.4.7 and NR 3.0.3.  Are you saying that there is no way to currently install NR on Ubuntu 16.04?

    Please advise as I'd like to get this working asap and am thankful to have software like this to run on my Linux box!

    God bless,

    Brad

  • edited April 2017
    Yes that build script is specifically for poco 1.4.7 and NR 3.0.3. There is currently no way to install NR on Ubuntu 16.04 via a package manager. You must install NR from source. The build script posted above will not work.

    NR 3.0.3 is no longer able to send reports because the SMTP server we use now requires TLS. NR 3.0.3 does not have support for TLS/SSL and is unable to communicate with that server.

    The current master branch of NR (found in the bitbucket link above) WORKS. You need to download it and compile it from source. You can also use the latest version of Poco with it (1.7.8 right now I think).

    Installation instructions are pretty simple:
    1. Clone/download NR from the bitbucket repo. If you want systemd support (you likely do) you'll want to check out the specific branch linked in this PR.
    2. Ensure you have the regular NR depedencies AND openssl installed. Use the latest version of poco or whatever is available in your package manager. I think you need at least 1.6??
    3. Do the regular build steps:
    4. autoreconf -vfi
      ./configure
      make
      sudo make install
    5. You should be all good then :) . Please report back and tell us how it works!
  • Awesome @Corey Watts, I'll try that today and let you know how it goes!  Thank you so much for your quick and helpful reply.

    God bless,

    Brad
  • edited April 2017
    I tried it this AM using poco v1.7.7 (pocolib-dev) I installed it seperately because it appeared as though the ubuntu package manager had a version older tha v1.6.  I also ensure openssh-dev was installed.  Unfortunately it seemed to still fail with the same error (although a lot more info was printed out).  Here's what appear to be the relievant details, let me know if you need anything else:

        net-responsibility: error while loading shared libraries: libPocoNet.so.47: cannot open shared object file: No such file or directory
        net-responsibility: error while loading shared libraries: libPocoNet.so.47: cannot open shared object file: No such file or directory
        Makefile:1901: recipe for target 'postinst' failed
        make: *** [postinst] Error 127


  • @Corey Watts Sorry Corey, I forgot to tag you in my comment.  I'm having issues with the build, not sure what to do next.


Sign In or Register to comment.